use strict;
my $str = 'line1
line2
line3
line4
line5
';
my $regex = qr/(\R?\R)\R+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";