const regex = /\{(.*?)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(.*?)\\}', 'gm')
const str = `akjsd{OrderNumber} aksjd {PatientName} aksjak sdj askdj {PatientSurname} askdjh askdj {PatientNumber} aksjd aksjd aksjd kajsd kasjd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);