re = /\{(.*?)\}/m
str = 'akjsd{OrderNumber} aksjd {PatientName} aksjak sdj askdj {PatientSurname} askdjh askdj {PatientNumber} aksjd aksjd aksjd kajsd kasjd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result