import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|\\|(?=(?:(?:(?:[^\"\\\\]|\\\\.)*\"){2})*[^\"]*$)";
final String string = "abc | efg || $something(\"arg\\\" 1\", \"arg 2||(a|b)\") || 123\n"
+ "env(\"test\") || env(\"ano\\\\ther\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}