$re = '/\|\|(?=(?:(?:(?:[^"\\\\]|\\\\.)*"){2})*[^"]*$)/mx';
$str = 'abc | efg || $something("arg\\" 1", "arg 2||(a|b)") || 123
env("test") || env("ano\\\\ther")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);