using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"login-actions\/([^&]*)";
string input = @"http://localhost:8080/auth/realms/master/login-actions/authenticate?code=u22yiDCDtV-jm3_1w2NP6HykFCTtePlgADFhFa17U3s&execution=570368df-fa0b-4bd1-9964-251d1448718e&client_id=security-admin-console"" ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}