package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`login-actions\/([^&]*)`)
var str = `http://localhost:8080/auth/realms/master/login-actions/authenticate?code=u22yiDCDtV-jm3_1w2NP6HykFCTtePlgADFhFa17U3s&execution=570368df-fa0b-4bd1-9964-251d1448718e&client_id=security-admin-console" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}