import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?= #lookahead\n"
+ " (\\(\n"
+ " (?>[^()]+|(?1))* #more comments\n"
+ " \\))\n"
+ ")";
final String string = "(+ (+ 4 3) ( - 3 2) 5)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}