re = /(?= #lookahead
(\(
(?>[^()]+|(?1))* #more comments
\))
)/x
str = '(+ (+ 4 3) ( - 3 2) 5)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end