using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\_IF\_\(\%([a-zA-Z0-9_]+)\=([a-zA-Z0-9_]+)\)\{(?:((?R))|[^{}])+\}\)";
string input = @"<div class=""right-side w-37"">
(_IF_(%verified=1){
(_IF_(%post_on_profile=1){
what is going on!!
})
})
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}