re = /\(\_IF\_\(\%([a-zA-Z0-9_]+)\=([a-zA-Z0-9_]+)\)\{(?:((?R))|[^{}])+\}\)/
str = '<div class="right-side w-37">
(_IF_(%verified=1){
(_IF_(%post_on_profile=1){
what is going on!!
})
})
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end