using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{.*?}}";
string input = @"Это какой-то тексст {{param1}} дорогие пупсики {{param2}} и нужно из него {{param3}} выдернуть параметры
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}