re = /{{.*?}}/m
str = 'Это какой-то тексст {{param1}} дорогие пупсики {{param2}} и нужно из него {{param3}} выдернуть параметры
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end