#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\s./-]*(?:\s\d+){4}(?:\s\$\d+\.\d+){2}$"
Local $sString = "Amount" & @CRLF & _
"2144-PL" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"2144-" & @CRLF & _
"PL Navy Blue 2 2 2 6 $11.50 $69.00" & @CRLF & _
"ETK-2097K-PL PLUS-TOP - BACK BUTTON TUNICS 95% RAYON 5% SPANDEX MADE IN USA" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"Black 2 2 2 6 $12.00 $72.00" & @CRLF & _
"Teal 2 2 2 6 $12.00 $72.00" & @CRLF & _
"ETK-2197-SW-" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"PL ETK-" & @CRLF & _
"2197- H.Grey/Burgu… 2 2 2 6 $14.00 $84.00" & @CRLF & _
"Off-White/Black 1 1 1 3 $14.00 $42.00" & @CRLF & _
"ETK-2143 Tops - 95% RAYON 5% SPANDEX MADE IN USA" & @CRLF & _
"S M L" & @CRLF & _
"Heather Grey 2 2 2 6 $10.50 $63.00" & @CRLF & _
"Royal Blue 2 2 2 6 $10.50 $63.00" & @CRLF & _
"Ruby Red 2 2 2 6 $10.50 $63.00" & @CRLF & _
"ETK2186-GD- Tops-Stripe Solid-95% Rayon 5% Spandex Made in USA" & @CRLF & _
"PL" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"Burgundy/Bur… 2 2 2 6 $11.00 $66.00" & @CRLF & _
"Ivory/Black 2 2 2 6 $11.00 $66.00" & @CRLF & _
"2139 - WP-PL PLUS TOP -95% RAYON 5% SPANDEX MADE IN USA" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"As Shown 2 2 2 6 $9.50 $57.00" & @CRLF & _
"ETK-2228" & @CRLF & _
"S M L" & @CRLF & _
"ETK- " & @CRLF & _
"2228 Off-White/Black 2 2 2 6 $9.50 $57.00" & @CRLF & _
"ETK-2149-PL" & @CRLF & _
"1XL 2XL 3XL" & @CRLF & _
"ETK-" & @CRLF & _
"2149- Taupe 2 2 2 6 $11.50 $69.00" & @CRLF & _
"BACK" & @CRLF & _
"ORDERED" & @CRLF & _
"White 2 2 2 6 $11.50 $69.00" & @CRLF & _
"Sub"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")