import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[[^\\]]*\\].*#.*$|#(.*)$";
final String string = "[A-Za-z # letters\n"
+ " 0-9_-.] # numbers and other characters\n\n"
+ "(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)\n"
+ "([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)\n"
+ "(\\||\\[|\\?) # match some stuff (escaped opening square bracket)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}