re = /^\[[^\]]*\].*#.*$|#(.*)$/m
str = '[A-Za-z # letters
0-9_-.] # numbers and other characters
(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)
([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)
(\\||\\[|\\?) # match some stuff (escaped opening square bracket)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end