using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z ]+) (\1)";
string input = @"Cher Cher
Humphrey Bogart Humphrey Bogart
Edgar Allen Poe Edgar Allen Poe
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}