re = /([a-zA-Z ]+) (\1)/
str = 'Cher Cher
Humphrey Bogart Humphrey Bogart
Edgar Allen Poe Edgar Allen Poe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end