package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([@#])(\S+)`)
var str = `@stackguy @flowguy I need to learn more advanced php #ilovephp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}