$re = '/([@#])(\S+)/';
$str = '@stackguy @flowguy I need to learn more advanced php #ilovephp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);