import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s+at ([^(]+)\\(([^:]+):(\\d+))\\)";
final String string = "ERROR java.lang.NullPointerException: Sample Java Logback Exception\n\n"
+ "at Sample.errorLevel3(Sample.java:35)\n\n"
+ "at Sample.errorLevel4(Sample.java:34)\n\n"
+ "at Sample.errorLevel5(Sample.java:30)\n\n"
+ "at Sample.errorLevel6(Sample.java:3)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}