re = /(?:\s+at ([^(]+)\(([^:]+):(\d+))\)/
str = 'ERROR java.lang.NullPointerException: Sample Java Logback Exception
at Sample.errorLevel3(Sample.java:35)
at Sample.errorLevel4(Sample.java:34)
at Sample.errorLevel5(Sample.java:30)
at Sample.errorLevel6(Sample.java:3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end