package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(^[a-hj-np-z][\d]{4}[a-z]{3}$|^[\d]{4}$)`)
var str = `C1417AUV
1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}