$re = '/(?i)(^[a-hj-np-z][\d]{4}[a-z]{3}$|^[\d]{4}$)/m';
$str = 'C1417AUV
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);