#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[^\]]*\]"
Local $sString = "[caption id=“attachment_2833” align=“aligncenter” width=“600”] IL MIO TESTO DA TENERE [/caption]" & @CRLF & _
"" & @CRLF & _
"[caption id=“attachment_2833” align=“aligncenter” width=“600”] text1 [/caption]" & @CRLF & _
" [caption id=“attachment_2833” align=“aligncenter” width=“600”] text2 [/caption]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")