use strict;
my $str = '[caption id=“attachment_2833” align=“aligncenter” width=“600”] IL MIO TESTO DA TENERE [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text1 [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text2 [/caption]';
my $regex = qr/\[[^\]]*\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}