import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Time(?:(?!User@Host:)[\\s\\S])*?User@Host: (?'user'root)\\[\\k'user'\\][\\s\\S]*?(?=(?:# Time|$))";
final String string = "# Time: 230706 17:12:48\n"
+ "# User@Host: sample[sample] @ localhost []\n"
+ "# Thread_id: 626784 Schema: sample QC_hit: No\n"
+ "# Query_time: 2.976557 Lock_time: 0.000178 Rows_sent: 0 Rows_examined: 3344231\n"
+ "# Rows_affected: 0 Bytes_sent: 195\n"
+ "SET timestamp=1688677968;\n"
+ "SELECT * from a;\n\n"
+ "# Time: 230706 17:15:51\n"
+ "# User@Host: root[root] @ localhost []\n"
+ "# Thread_id: 627770 Schema: sample QC_hit: No\n"
+ "# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228\n"
+ "# Rows_affected: 0 Bytes_sent: 195\n"
+ "SET timestamp=1688678151;\n"
+ "select * from cs;\n\n"
+ "# Time: 230706 17:13:37\n"
+ "# User@Host: sample[sample] @ localhost []\n"
+ "# Thread_id: 627027 Schema: oiemorug_wp598 QC_hit: No\n"
+ "# Query_time: 3.901325 Lock_time: 0.000145 Rows_sent: 0 Rows_examined: 3851050\n"
+ "# Rows_affected: 0 Bytes_sent: 195\n"
+ "SET timestamp=1688678017;\n"
+ "SELECT * from b\n\n"
+ "# Time: 230706 17:15:51\n"
+ "# User@Host: root[root] @ localhost []\n"
+ "# Thread_id: 627770 Schema: sample QC_hit: No\n"
+ "# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228\n"
+ "# Rows_affected: 0 Bytes_sent: 195\n"
+ "SET timestamp=1688678151;\n"
+ "select * from cs";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}