const regex = /# Time(?:(?!User@Host:)[\s\S])*?User@Host: (?'user'root)\[\k'user'\][\s\S]*?(?=(?:# Time|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# Time(?:(?!User@Host:)[\\s\\S])*?User@Host: (?\'user\'root)\\[\\k\'user\'\\][\\s\\S]*?(?=(?:# Time|$))', 'g')
const str = `# Time: 230706 17:12:48
# User@Host: sample[sample] @ localhost []
# Thread_id: 626784 Schema: sample QC_hit: No
# Query_time: 2.976557 Lock_time: 0.000178 Rows_sent: 0 Rows_examined: 3344231
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688677968;
SELECT * from a;
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs;
# Time: 230706 17:13:37
# User@Host: sample[sample] @ localhost []
# Thread_id: 627027 Schema: oiemorug_wp598 QC_hit: No
# Query_time: 3.901325 Lock_time: 0.000145 Rows_sent: 0 Rows_examined: 3851050
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678017;
SELECT * from b
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}