using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}:\d{2}:\d{2},\d{3}$";
string input = @"1
00:00:01,357 --> 00:00:03,323
You took this case
without running it by me.
2
00:00:03,359 --> 00:00:04,825
- Jessica--
- That's enough. Dump it.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}