$re = '/\d{2}:\d{2}:\d{2},\d{3}$/mi';
$str = '1
00:00:01,357 --> 00:00:03,323
You took this case
without running it by me.
2
00:00:03,359 --> 00:00:04,825
- Jessica--
- That\'s enough. Dump it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);