package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z]`)
var str = `ThisAreValidLines
But$Here There 1234 are in$val1d characters`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}