$re = '/[^a-zA-Z]/';
$str = 'ThisAreValidLines
But$Here There 1234 are in$val1d characters';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);