import re
regex = re.compile(r"(([0-2][0-9]|3[0-1])([0][0-9]|[1][0-2])(19|20[0-9][0-9]))[.]zip")
test_str = "09062015.zip"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")