using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{myplugin:start=(.*):.*stop=(.*)}(.*){\/myplugin}";
string input = @"{myplugin:start=2023-02-01:stop=2024-02-02}contenu {/myplugin}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}