// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){myplugin:start=(.*):.*stop=(.*)}(.*){\/myplugin}").unwrap();
let string = "{myplugin:start=2023-02-01:stop=2024-02-02}contenu {/myplugin}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}