$re = '/(?:\(|(?!^)\G)\K[+*\/-]?\d+(?=[^()]*\))/';
$str = '50-60*70/50+(1+7-(9+51))+5*9/10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);