re = /(?:\(|(?!^)\G)\K[+*\/-]?\d+(?=[^()]*\))/
str = '50-60*70/50+(1+7-(9+51))+5*9/10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end