package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^commits:[ ]{0,}(.*)`)
var str = `commits:56af25a...d3fead4
Commits: [56af25a...d3fead4](https://github.com/Glimpse/Semantic-Release-Notes/compare/56af25a...d3fead4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}