re = /^([\u00C0-\u1FFF\u2C00-\uD7FF]+(?:[^a-z\u00C0-\u1FFF\u2C00-\uD7FF]+[\u00C0-\u1FFF\u2C00-\uD7FF]+)*) [a-z]+[^\u00C0-\u1FFF\u2C00-\uD7FF]*$/i
str = 'Шедевры православной музыки - 20 золотых православных песен'
# Print the match result
str.match(re) do |match|
puts match.to_s
end