const regex = /(0[1-9]|[12]\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\s+(0\d|1[1-2])\.([0-5]\d){1,2}(A|P)\s\&[A-Z]{2}\d\s+[A-Z]{4}\s+(\d|\*){12}\s\w\?\s\w\?\s\Ã \?\&\w{2}\d\w/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|[12]\\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\\s+(0\\d|1[1-2])\\.([0-5]\\d){1,2}(A|P)\\s\\&[A-Z]{2}\\d\\s+[A-Z]{4}\\s+(\\d|\\*){12}\\s\\w\\?\\s\\w\\?\\s\\Ã \\?\\&\\w{2}\\d\\w', '')
const str = `17-08-15 11.04A &AD4 USER 0002******** j? j? Ã ?&AD4N
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}