re = /(0[1-9]|[12]\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\s+(0\d|1[1-2])\.([0-5]\d){1,2}(A|P)\s\&[A-Z]{2}\d\s+[A-Z]{4}\s+(\d|\*){12}\s\w\?\s\w\?\s\Ã \?\&\w{2}\d\w/
str = '17-08-15 11.04A &AD4 USER 0002******** j? j? Ã ?&AD4N
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end