package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([a-z].*[A-Z])|([A-Z].*[a-z])) \(ecg\)`)
var str = `Test (ecg)
test (ecg)
tesT (ecg)
TEST (ecg)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}