$re = '/(([a-z].*[A-Z])|([A-Z].*[a-z])) \(ecg\)/m';
$str = 'Test (ecg)
test (ecg)
tesT (ecg)
TEST (ecg)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);