# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(channel\/|user\/)(?P<unslash>[\w_-]+)|\/(channel\/|user\/)(?P<slash>[\w_-]+)\/"
test_str = ("http://www.youtube.com/user/TheJuicyJVEVO\n"
"https://www.youtube.com/channel/UC4SusBgD3b1G5cCh_gjA81g\n"
"http://www.youtube.com/user/fabrikaband?gl=RU&hl=ru\n"
"https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/featured\n"
"https://www.youtube.com/channel/UCd2R33j8_ZtNtP2HmXNqAGA/videos?a=b&b=c\n"
"https://www.youtube.com/duranduran\n"
"https://www.youtube.com/r3hab")
matches = re.finditer(regex, test_str, re.UNICODE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.