using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"symbol\s+""([A-Z]{2,5})";
string input = @" New York Stock Exchange (NYSE) under the symbol ""KDMN.""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}