const regex = /symbol\s+"([A-Z]{2,5})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('symbol\\s+"([A-Z]{2,5})', '')
const str = ` New York Stock Exchange (NYSE) under the symbol "KDMN."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}