import Foundation
let pattern = #" ?[^*]me"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
she saw me now
she saw *me now
she saw +me now
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" foo"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)