const regex = /^(?=.*\D{2,})[-.^\d]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\D{2,})[-.^\\d]+$', 'gm')
const str = `-1.2^-2.4
-12^2.4
-1^2
but not
1^2
1+2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}