$re = '/^(?=.*\D{2,})[-.^\d]+$/m';
$str = '-1.2^-2.4
-12^2.4
-1^2
but not
1^2
1+2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);