package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<q>'|"|`)\w+(\k<q>)`)
var str = `"testt"
'testt'
"testt'
'testt"
\`testt\`
\`testt'
"testt\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}